19th April 2024

Dallas, TX [SUPREME SERVERS] Dallas Data centre connectivity issues.

Our monitoring system has alerted us to an issue with Our Dallas data centre.

Engineers are working to resolve the issue.

We apologize for any inconvenience this may cause.

UPDATE: Network engineers have identified the issue as a fiber outage and are working to resolve the issue.

UPDATE: Our engineers are currently in contact with the fiber provider. We hope to have an ETA soon.

UPDATE: 04:45am - We are still working with the team over at our Dallas data centre to resolve this issue, We hope to have a ETA soon.

UPDATE: 06:10am - We are continually monitoring the situation, the fibre provider is still working on the issue and will update us as soon as an ETA is available.

UPDATE: Connectivity has been restored, thank you for your patience.