24th July 2023

Miami, FL Outage at Miami Data Center - Monday 24th July 2023, 5.47am EST

Resolved 7:30am:

We can now confirm that services have been restored at our Miami data center. If you are continuing to experience issues, please log a ticket via the Billing and ticket portal and we will assist individually.

Thank you for your patience.


Update 6:37am EST

investigations are ongoing, this is being treated as a critical priority and we are working with the facility provider to resolve as quickly as possible. We apologize again for any inconvenience caused.

Our Billing and ticket portal is currently offline, which will unfortunately affect all customers.


Our monitoring system has alerted us to an issue with connectivity at our Miami data center. Please stand by for further updates as our engineers investigate.

We apologize for any inconvenience this may cause.